Crash Course Unity 2D

Building 2D platformers in Unity




Goal

Get comfortable with Unity game editor
Create an interactive 2D environment
Learn lots of 2D development terms

A brief start in C# programming



Starting a new project

Step 1: Click "New”




Starting a new project

Step 2: Type in a project name and the folder it'll be

created in.
Note: Unity will create a new folder with the project’s name
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Starting a new project

Step 3: Click on “2D" above the “Asset packages...” button




Starting a new project

Step 4: Click "Asset packages...”,  Assetpackages
and check “2D.”

'l I-l'l.
] I
0 =

—
L

Lastly, click "Done.”
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Note: the rest of the packages
can be imported at any time!




Starting a new project

Step 5: Finally, click “Create project”




About Unity
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What is Unity?

e A What-You-See-Is-What-You-Get (WYSIWYG) 3D & 2D
Game Engine

e Many built-in features
o Physics, Sound, Scripting, Gamepad support, Plugins, and
more!
e Builds to many platforms
o PC, Mac, Linux, HTML5 + WebGL, iOS (iPhone + iPad),
Android, Windows 10, Windows 8, Kindle Fire, PS4, PS3,

PS VITA, Xbox One, Xbox 360, Wii U, New 3DS, Ouya,
Samsung TV, Tizen



Licenses and Fees

e Personal license (Free!)
o Build to Windows, Mac, Linux, Webplayer, HTML5 + WebGL, iOS,

Android, and Windows 10

o C# and Javascript(-ish) scripting support
o Totally OK to sell your game! There’s no royalty fees.

m Exception: if your company’s gross revenue/budget exceeds
$100,000, you need to purchase...
e Pro license ($1,500 or $75/month)
o Required if company gross revenue/budget exceeds $100,000

o Supports up to 2 computers per license
o Access to more platforms (PS4, Xbox One, Wii U, etc.)
O

Allow customizing splash screen



Licenses and Fees

e More about the Pro license ($1,500 or $75/month)

o Pro license is mainly for access to more online services (team-

synchronization, better analytics service, better online multiplayer
servers, cheaper asset store prices, etc.)

o The $1,500 perpetual license does not cover whole-number upgrades
(e.g. version 5.3.4 to 6.0.0). While these licenses can be upgraded, it
will cost extra.

o The minimum length of the $75/month subscription is 12 months.
These licenses do cover all upgrades.

o If you do get a Pro license, and plan to release on iOS and/or Android,
they each will cost an extra $1,500 or $75/month.



Making a game
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Importing stuff

W N

Go to wp.me/a5G4dR-g4, and click the Crash-Course-
Unity-2D-Assets link to download a ZIP file.

Unzip the file with your favorite file browser.

Move all of the unzipped files
into the project’s Assets folder. W~
Switch to Unity. T e 7

ﬁ


http://wp.me/a5G4dR-q4
http://www.techvalleygamespace.com/wp-content/uploads/2016/04/Crash-Course-Unity-2D-Assets.zip
http://www.techvalleygamespace.com/wp-content/uploads/2016/04/Crash-Course-Unity-2D-Assets.zip
http://www.techvalleygamespace.com/wp-content/uploads/2016/04/Crash-Course-Unity-2D-Assets.zip

Project Pane

e Displays the contents of the Assets folder.
o Automatically syncs with the folder if there’s any changes

e Has a search bar to make it easier to find assets
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Add a sprite to a new scene

1. Select landscape.png in the
Project pane.

2. Drag-and-drop landscape.
png into the Scene pane.

3. Press Ctrl+S/Cmd+S to save
the scene (or “File->Save
Scene”)

Edit Assets  GameObject Compo
Mew Scene Ctrl+M |

Open Scene Ctrl+0 |

Save Scene Ctrl+5
Save Scene as. Ctri+5hift+5




Quick lexicon review

e Assets
o Industry-wide term for any files used in the game
o For Unity, that’s anything inside the Assets folder
e Sprite
o Industry-wide term for a portion of a 2D image
o Can representative of a frame in an animation

o Usually made in a specialized program, e.g. Photoshop, GIMP, Krita,
Paint, etc.

e Scene
o Unity’s term for files storing a collection of objects
o Holds references to assets in the Assets folder
o Has a *.unity file extension



Importing Images

Unity can natively import:

Photoshop (*.psd)

PNGs (*.png)

JPEGs (*.jpg, *.jpeg)
Un-animated GIFs (*.gif)
Paint (*.bmp)

TGAs (*.tga)

and more!



Scene Pane

e A 2D & 3D view of a scene where objects can be
positioned, rotated, and scaled.




Navigating the scene in 2D

e 2-button mouse:
o Left-click to select objects
o Hold the right mouse button to pan
o Hold alt and right mouse button to zoom in and out

e 3-button mouse:
o Left-click to select objects
o Hold the right mouse button to pan
o Click and hold on the scroll wheel also pans
o Scroll wheel to zoom in and out

e Hold shift to pan/rotate/zoom faster
e When the mouse is in the Scene pane, tap “F” to focus on
the currently selected object



Adding a controllable

Let’s add a prefab (short for prefabricated
object) with platformer controls
1.

2.

obot

€ Game
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In the Projects pane, search for
"CharacterRobotBoy"

Drag-and-drop "CharacterRobotBoy.
prefab" /\

into the Scene pane. s 0] [ —
Position the robot s _jeszot
above the landscape an
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Hierarchy Pane

e Displays all the Game Objects (i.e.
content) in the scene in a tree hierarchy.

e Game Objects selected in the Hierarchy- 5o S
pane are also selected in the Scene-pane, | &a.conome
and vice versa.

e You can change the order of the objects
by dragging them up and down

e Dragging objects into another turns that
object into a child (I'll go over this later)




Quick lexicon review

e Game Objects
o Unity’s term for any individual object

o Can be active or inactive
o Every entry in the Hierarchy pane is a game object

e Prefab

o Unity’s term for prefabricated game objects

o Files with *.prefab file extension

o Allows copying a group of game objects from one scene to another

o Also allows synchronizing data between a group of game objects,
regardless of what scene it's in (more on this later)



Playing the Game

1. Press the play button. 2Lt L]
2. Observe your robot...fall through the floor.
3. Press the play button to stop the game.

4. What are we missing?



Adding a Collider

2.

The landscape needs a collider
1.

— R a
= Hierarchy | = -
| Ereate =| (oAl

Main Camera

landscape

In the Hierarchy pane on the left side of
the screen, select landscape.
In the Inspector pane on the right side e
of the screen, click "Add Component" =
Select "Physics 2D -> Polygon Collider
2D"




Editing the Polygon CoIIider

1. Click the button next to “Edit Collider.” . Sl

2. Move the green nodes on the collider to the cIosest
corner of the landscape

3. Add more corners by left-clicking in the middle of a long
edge

4. Remove corners by holding ctrl (the node will turn red),
then left-click a node

5. When finished, click the button
next to “"Edit Collider” to turn
the collider editor off




Playing the Game

1. Press the play button. 2Lt L]

2. Use the arrow keys (or WASD) to move, space to jump,
and ctrl to crawl.

3. Marvel at your own work.



Inspector Pane

e Displays the properties and details
on a selected object/file, both in
Project pane and Scene pane.

e One can edit the properties of an
object here.
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Quick lexicon review

e Components
o Unity’s term for containers with specialized information
o Game objects retain a list of components (such as Colliders)
o (Can be enabled or disabled
o Every entry in the Inspector pane is a Component

e C(olliders

o Industry-wide term for shapes representing the boundaries of an
object
o Used by the physics engine to determine where objects collide



Types of colliders

e Polygon Colliders
o Colliders that can be shaped to any polygon
o Expensive and inefficient
o Best for static, non-interactable convex shapes, like buildings

e Edge Colliders

o Like Polygon Colliders, without any area

o Best for static, non-interactable concave shapes, like caves
e Box Colliders

o Rectangle-shaped colliders

o Very efficient, great for interactable shapes
e Circle Colliders

o Circle-shaped colliders (no oval support)



Making the camera move

1. Inthe Project Pane, search = s = S8 o e
for “"Camera2DFollow” /m» (e}

753 Assets

2. Drag the C# script from the e

Project pane to the Main Camera in the o
Hierarchy pane
3. Finally, drag the CharacterRobotBoy into the s o
Target field in “*Camera 2D Follow” scrip
(also, play around with other variables) A iy
4. Play the game! e o ul | — %“
Target None (Transform) ©




Making the landscape bigger

radio button on the upper-left hand corner
2. Click on the landscape in the Scene Pane
3. Make the landscape larger by clicking on the
corner or edges of the sprite’s bounding box
4. Hint: hold shift to make the corner-scaling
proportiona
5. Play the game!




Adding invisible walls

1. Click on Create -> Create Empty in the  leme- &
Hierarchy pane Crete Empty Chid

2. In the new object, GameObject, add
Physics 2D -> Box Collider 2D via the
inspector

3. Click on the 4-way arrow control, and move
the collider to the left of the landscape by
clicking the red arrow, and dragging to the
left




Adding invisible walls

1. In the Inspector, click the Edit Collider ™™™ ctteragy
bUtton Material NondgPhy

2. Drag the 4 nodes so the collider is as tall as
possible. Also make the collider wide to
prevent errors.

3. Use the Ctrl+D/Cmd+D shortcut to duplicate
the wall and place them to the right of the
landscape




Manipulating objects

Pan View (Q)
Translate (W)
Rotate (E)

Scale (R)
2D Sprlte (T) Translate (W) Rotate (E) Scale (R) Move 2D Scale 2D Rotate 2D

e Controls to toggle object’s reference point: el St

e Play Game controls, from left to right:
o Play game (or if already playing, stop game)
o Pause game (or if already paused, resume game)
o Move forward one frame

0O O O O O




Adding special platforms

== 2

5.

Drag jumpThroughPlatform.png from the Project
pane to the scene, and place it above the landscape
In the inspector, add Physics 2D -> Box Collider
2D & Physics 2D -> Platform Effector 2D to the

platform a T ‘
Observe warning: || smeshes™ TTE0H
As noted by the warning, check the ~ s Collier 2
“Used By Effector” field o o
Play the game, and jump through the = usdereeer &

platform!



About Effectors

Effectors modify the behaviour of colliders affecting
Rigidbody 2D

e Platformer Effector 2D

o Simulates collision only if the Rigidbody 2D hits it at a specific angle
o Useful for jump-through platforms

e Buoyancy Effector 2D

o Turns a collider into a water body that lets Rigidbody 2D with low
density to float, and higher density to sink slowly

e Area Effector 2D

o Makes a collider push and/or objects to a specified direction
o Useful for simulating wind, or creating boost pads



About Effectors

e Point Effector 2D

o Creates an outward or inward force in a collider’s area
o Useful for explosions and magnetism

e Surface Effector 2D

o Makes the surface of a collider push objects in a specified direction
o Useful for conveyer belts



Using Sprite Editor

1. Click on physicsProps.png in the Project pane
2. In the Inspector pane, change the “Sprlte Mode”
to “"Multiple”
3. Finally, click the “Sprite Editor” button
at the bottom of the inspector P e
4. If a warning pops-up, click “Appl_yh

Pixels Per U ;
ixels Per LUni t& Multiple
Unapplied import settings x
ST ] Sprite Editar
Unapplied import settings for
'AssetsphysicsProps.png'.
Apply and continue to sprite editor or cancel,

Inspectul |
, physicsProps Import Setting:

=

Single




Using Sprite Editor

With the Sprite Editor, you can cut-out multiple sprites from a
single image file (called sprite sheet). This makes the game more
efficient (it loads less files). — s==———— m———




Using Sprite Editor

1. Click and drag at the sprite sheet’s upper-left |
hand corner, then down the the lower-right
corner of the crate, creating a green square
cut-out boundary

2. In the upper-left hand corner of the dialog,
click on Trim to make the cut-out tighter

3. On the lower-right hand pop-up, change the
name to “crate” — 3

4. Repeat these steps for the other elements, "
with names like “ball” and “spring”




Using Sprite Editor

1. Click the Apply button on the upper-right hand
corner of the dialog —
Close the Sprite Editor

On the Project Pane, click on the arrow on the

physicsProps.png to expand all of its sprites
=-8- 13

physicsPra A
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Adding Interactable objects

. On the Project Pane, drag-and-drop
the crate from physicsProps.png
to the scene

v B ¥ Box Collider 2D

2. As usual, add a Box Collider 2D o ;:iiﬁi
component e

3. Using the same method, add .
“Physics 2D -> Rigidbody 2D" >

4. Play the game!

M Box Collider ZD




Making weird shapes

. Drag the ball sprite into the scene

2. In the Scene pane, position the new

ball on a corner of the crate

Add a Circle Collider 2D on the ball

In the Hierarchy pane, drag & drop

the ball into the crate. The ball should

now be a child of crate.

5. Play the game, and push the crate
around!

Sl




Quick lexicon review

e Rigid Body

O
O

Industry-wide term for a moving and/or interactive physics objects
Contains information such as mass, drag, and center-of-gravity

o Turns a group of colliders (including those in the children) into a

single, interactable shape

e Child

©)

Industry-wide term for an object whose position, scale, and rotation
follows that of another object: the parent
In Unity, they appear as nested entries in the Hierarchy tree view

Trivia: this “following parent” calculation process is known as forward
kinematics, a term in 3D animations



Duplicating the crate

1.

2.

Drag & Drop the crate from the Hierarchy pane to
the Project pane. This creates a new Prefab.

Drag & Drop the crate prefab from the Project pane
to the Scene pane as many times as you like. This
will create many copies of crate.

| w57 Favorites
00 Al Materials
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Changing physics

1. Click the “Create” button on the upper——— "«

3 Project |

left hand corner of the Project Pane
2. Select “Physics2D Material”
3. Name the new file, “bouncy~
4, In the Inspector pane, chanm’ postr Mk
bounciness to 1.2 (as in, 120%) N Pz

-Elnspectur

\/. bouncy
Frictian 0.4
Bounciness 1



Changing physics

Drag the spring sprite to the scene,
and place them on top of a flat
surface

Click on the spring in the scene
Add a Box Collider 2D via the
Inspector

Drag-and-drop the bouncy physics
material

Play the game, and jump on top of
the spring!

v M ¥ Box collider 2D

b | Edit Cal




Fixing rough edges

) Inspector

The robot clinging on any vertical edge can be \/® fricionless

fixed by making the robot frictionless — =

1. Create a Physics2D Material in the project /'aauncmess o
pane again T T

2. Name the new file, “frictionless” S""j

3. In the Inspector pane, change the friction to N—
0 (as in, 0%)

4, Select CharacterRobotBoy in the scene :“@:giiil‘f’l’f::fé’h;m, S—

5. Change the Material field in both Circle I e e e
Collider 2D and Box Collider 2D to Ewﬁj
“frictionless” — =




Quick lexicon review

e Physics Material

©)

Industry-wide term for how objects are supposed to interact to a

collider
m Adjusts how slippery and bouncy an object can be

In Unity, materials are files (*.physicMaterial2D) shared between
game objects

Changing a physics material’s properties will update all game objects
with the same physics material



Adding background

1. Drag the background.png
from Project pane into the :
scene

2. Resize the background to take
up the entire landscape

3. ...Except it also covers the 7 /[
landscape




Adding background

¥ |5l (M Sprite Renderer
1. Click on the “Sorting Layer” property in the o D
Sprite Renderer component in the Inspector, S
and click “Add Sorting Layer...” ey
2. Click on the “+" sign below Sorting Layer. ;'E}—
Name the new layer as “Background” = Laver bfait
3. Use the double-lines on the left entry to drag ~ [rteve= =N

Background above Default. Layers lower on
the list are drawn on-top.

4. Click on the background again, and change it’s
“Sorting Layer” property to “Background.” e B

ﬁ Default

Background
OEfanrt




Adding more decoration

1. In the Project pane, click on [ ]
backgroundProps.png s S |

2. In the Inspector pane, change the =

“Sprite Mode” to “Multiple,” and click :

the “Sprite Editor” button e man

If a warning pops-up, click “Apply”

On the Sprite Editor dialog, expand

“Slice” at the upper-left hand corner, 2P e,

and click the “Slice” button

== 2
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Adding more decorations

1. Click “Apply” on the upper-right hand corner of the Sprite
Editor dialog, then close the dialog

2. Expand backgroundProps.png in the Project Pane, and
drag any one of the sprites into the scene

3. Change the sprite’s "Sorting Layer” property to
“Background”

4. Change the “"Order in Layer” property to 1




About drawing order

e If 2 sprites have the same Sorting Layer and Order in
Layer, and are placed at the same location, they will

appear to flash.
o Essentially, both sprites are fighting to be drawn on-top of each other
o Commonly known as “clipping”

e Sorting Layer broadly groups sprites to be drawn in a
specific order (lower in the layer list = drawn on top)

e Order in Layer adds finer controls to the draw order of
individual sprites in a layer (larger number = drawn on

top)



Adding music

1. Select CharacterRobotBoy in scene T
2. In the Inspector pane, click "Add
Component” - N @
3. Select "Audio -> Audio Source" = EEETe”  wmsmesa:
4. In the Project pane, drag-and-drop s
Crash Course Unity 2D Theme.ogg | ‘ooae =
into the Audio Source's "Audio Clip" L
property o —
5. Check the “Loop” field et P
6. Play the game! Rever Zone x| -




Importing audio

Unity can natively import:
e MP3 (*.mp3)

o Lossy, compressed. Best for music, especially in mobile devices

e OGG (*.099)

o Lossy, compressed. Best for music, especially PC and consoles

e WAV (*.wav)

o Lossless, uncompressed. Best for short sound effects

e AIFF (*.aif, *.aiff)

o Lossless, uncompressed. Best for short sound effects



Adding a sound

1. Select a crate in the Scene pane
2. In the Inspector pane, add an Audio Source
on the crate .
3. In the Project pane, drag-&-drop TP
bumpSound.wav into the "Audio Clip"
property
4. Play the game!

v ] M Audio Source
AudioClip -

Output

LT RTE Y




Adding a Script

R Wi

=

Select the crate in the Scene pane

In the Inspector pane, click "Add Component”

Select "New Script”
Change the script type to CSharp, and the
script name to "PlaySoundOnCollision”
Click “Create and Add”

Double-click "PlaySoundOnCollision" in the
Inspector pane to open Editor

aaaaaaaa
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Copy the Following:

using UnityEngine;
public class PlaySoundOnCollision : MonoBehaviour
AudioSource audioCache;
vold Start () {
audioCache = GetComponent<AudioSource> () ;
}
vold OnCollisionEnter2D(Collision2D info) {
audioCache.Stop () ;
audioCache.Play () ;



Finishing the Sound Effect

Save the script (under “File” in the menu bar)

Switch to Unity

Select the crate in the Scene pane

Under the Inspector, uncheck Audio Source's "Play-On

LJIZ uuuuuuuuuuu

R Wi

AWa ke AudioClip hit
Qutput None (Audio Mixer Group i
Mute -
5. Play the game! = —— | =
" " Bypass Listener Effects |
sssssssssssssssss -




Script Summary

AudioSource audioCache;
void Start () {

| —

audioCache = GetComponent<AudioSource> () ;

The start () function runs when the game starts
GetComponent<AudioSource> () gets the Audio Source
component from the Game Object this script is attached to
audioCache = GetComponent<AudioSource> () stores
the Audio Source Component in a variable, audioCache



Script Summary

volid OnCollisionEnter?2D(Collision2D info) {
audioCache.Stop () ;
audioCache.Play () ;

1. The OnCollisionEnter () function runs when the
Rigidbody collides with a collider

2. audioCache.Stop () makes the sound effect stop,
resetting it back from the beginning

3. audioCache.Play () makes the sound effect play
again



Sound Effect polish

Rl

Change the Audio Source’s Spatial Blend to | stereep=n T e
1 (full 3D) =
Play the game. The sound will be quiet due

to the “ear” placed on the camera. 5721 oateer @e

Click on the Main Camera in the Hierarchy =
In the Inspector, click on the gear at the Ef::;—‘ s
right of the Audio Listener, and select Lo A ComComponett [
“Copy Component”

Click the gear again, and select "Remove

Component”




Sound Effect polish

1. Click on the CharacterRobotBoy in the  sterern TS L

H |era rchy Spatial Blend | o 3%11;
2. In the Inspector, click on the gear on any
\\ v =] M Audio Source f+]
component, and select “Paste Component auetie e :

AS NeW" :I:::Ut Remove Component
- Bypass Effe Move U
3. Play the game. Notice crates play sounds  memrm oo
louder if you're closer. L R

Paste Component As New I/\\}
Loop - _ Srp



Synchronizing Prefabs

You might notice only one crate plays a sound effect. Since
it's a prefab, though, we can synchronize its state with the
other crates.
1. Click on the crate with the sound effect
2. At the top of the inspector, click “Apply”
3. Note the bolded fields in the Audio Source turned to
normal font style [0 tnapecor ] R
4. Play the game! (w5 —

-
Tag | Untagge d # | Layer | D
Prefab | Select |




Save project

Select “File -> Save Project”

e Saves project settings, such as Build Settings

e Saves anything import settings in the Project Pane

e Saves any Unity files that isn’t a scene, such as
materials, prefabs, physics materials, etc.

Mew Scene

Open Scene

Save Scene

Save Scene as... C

Mew Project...
Open Project...

Save Project



Building an Executable

1. Save the scene with Ctrl+S/Cmd+S.
2. In the file menu, select "File -> Build
Settings..."

Mew Scene Ctri+N |
Open Scene Ctrl+0
Save Scene Ctrl+5
Save Scene as... Ctrl+5Shift+5
Mew Project...

Open Project...

Save Project

Build Settings... Ctrl+ Shift+B
Build & Run Ctrl+B
Build in Cloud...

Exit




Building an Executable

1. Drag & drop your scene in the Project pane into
the Build dialog

2. Change the Target Platform
to your computer's OS

3. Click the "Build" button,
and select a folder that
Isn’t in your project




Congratulations!

Any guestions?




Supplementary materials

e unity3d.com/learn/tutorials
a. Official site full of tutorials on individual
Unity feature
b. Includes in-depth C# programming
tutorials!



http://unity3d.com/learn/tutorials
http://unity3d.com/learn/tutorials

Supplementary materials

e docs.unity3d.com/Manual/index.html
a. Manual for Unity, including scripting
documentation
b. Alternatively, click the “help” icon in the
Inspector pane to bring up documentation

(G¥
Nt |



http://docs.unity3d.com/Manual/index.html
http://docs.unity3d.com/Manual/index.html

Using Version Control?

e Select “Edit -> Project Settings ->
Editor”

e In the Inspector, change “Version
Control Mode” to “Visible Meta Files”

e Change "Asset Serialization Mode” to. =\
“Force Text” T\

e Select “File -> Save Project”

e \ersion the project’s “Assets” and
“ProjectSettings” folders (the rest can
be ignored)

IIIIIIIII




